Fixing Plesk 7.5.4 Updater Problems

Problem:

If you decide to do some updating on Plesk 7.5.4, and none of the packages install, you may want to check /tmp/autoinstaller.log for this:

Installing selinux-policy-targeted-sources-1.17.30-2.52.1.noarch.rpm
error: Failed dependencies:
selinux-policy-targeted = 1.17.30-2.52.1 is needed by selinux-policy-targeted-sources-1.17.30-2.52.1.noarch

Typically, this happens on newer systems that are being reloaded with older Plesks.

 

Solution:

# rpm -e `rpm -qa | grep selinux-policy`
# rpm -Uvh http://www.eng.lsu.edu/mirrors/redhat/rhel4.ws/install/RedHat/RPMS/selinux-policy-targeted-1.17.30-2.52.1.noarch.rpm

Run the update again and you should be in good shape.